<!DOCTYPE html>
<html lang="en-GB">
<head>
<meta charset="UTF-8" />
<meta name="theme-color" content="#000000" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://gadgets-africa.com/xmlrpc.php">
<link href="https://gadgets-africa.com/wp-content/themes/the-next-mag/css/mainstyle.css?v=1.6.2" rel="stylesheet">
<link rel="manifest" href="manifest.json">
<script type="text/javascript">
(function(i,s,o,g,r,a,m,n){
i['moengage_object']=r;t={}; q = function(f){return function(){(i['moengage_q']=i['moengage_q']||[]).push({f:f,a:arguments});};};
f = ['track_event','add_user_attribute','add_first_name','add_last_name','add_email','add_mobile',
'add_user_name','add_gender','add_birthday','destroy_session','add_unique_user_id','moe_events','call_web_push','track','location_type_attribute'];
for(k in f){t[f[k]]=q(f[k]);}
a=s.createElement(o);m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m);
i['moe']=i['moe'] || function(){n=arguments[0];return t;}; a.onload=function(){if(n){i[r] = moe(n);}};
})(window,document,'script','https://cdn.moengage.com/webpush/moe_webSdk.min.latest.js','Moengage');
Moengage = moe({
app_id:"",
debug_logs: 0
});
</script>
<script type="application/javascript">var ajaxurl = "https://gadgets-africa.com/wp-admin/admin-ajax.php"</script><style type="text/css">			.heateorSssInstagramBackground{background:radial-gradient(circle at 30% 107%,#fdf497 0,#fdf497 5%,#fd5949 45%,#d6249f 60%,#285aeb 90%)}
											.heateor_sss_horizontal_sharing .heateorSssSharing,.heateor_sss_standard_follow_icons_container .heateorSssSharing{
							color: #fff;
						border-width: 0px;
			border-style: solid;
			border-color: transparent;
		}
				.heateor_sss_horizontal_sharing .heateorSssTCBackground{
			color:#666;
		}
				.heateor_sss_horizontal_sharing .heateorSssSharing:hover,.heateor_sss_standard_follow_icons_container .heateorSssSharing:hover{
						border-color: transparent;
		}
		.heateor_sss_vertical_sharing .heateorSssSharing,.heateor_sss_floating_follow_icons_container .heateorSssSharing{
							color: #fff;
						border-width: 0px;
			border-style: solid;
			border-color: transparent;
		}
				.heateor_sss_vertical_sharing .heateorSssTCBackground{
			color:#666;
		}
				.heateor_sss_vertical_sharing .heateorSssSharing:hover,.heateor_sss_floating_follow_icons_container .heateorSssSharing:hover{
						border-color: transparent;
		}
		
		@media screen and (max-width:783px) {.heateor_sss_vertical_sharing{display:none!important}}@media screen and (max-width:783px) {.heateor_sss_floating_follow_icons_container{display:none!important}}</style>
<meta name="google-site-verification" content="vVS3ShPdfdeAbMaWy9_s2d9yVnlg4Ej-AwHJ8rDmIZ0" />

<title>Scientists are Teaching Spinach How To Send Emails</title>
<meta name="description" content="I love Spinach. So, you can imagine my shock when I heard that Spinach now has the capability to send emails. This experiment is part of a wider field of..." />
<meta name="robots" content="index, follow" />
<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://gadgets-africa.com/2021/02/21/spinach-sending-emails/" />
<meta property="og:locale" content="en_GB" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Scientists are Teaching Spinach How To Send Emails" />
<meta property="og:description" content="I love Spinach. So, you can imagine my shock when I heard that Spinach now has the capability to send emails. This experiment is part of a wider field of..." />
<meta property="og:url" content="https://gadgets-africa.com/2021/02/21/spinach-sending-emails/" />
<meta property="og:site_name" content="Gadgets Africa" />
<meta property="article:publisher" content="https://www.facebook.com/gadgetsafrica/" />
<meta property="article:published_time" content="2021-02-21T09:54:02+00:00" />
<meta property="og:image" content="https://i1.wp.com/gadgets-africa.com/wp-content/uploads/2021/02/Untitled-design-9-1.jpg?fit=1920%2C1080&#038;ssl=1" />
<meta property="og:image:width" content="1920" />
<meta property="og:image:height" content="1080" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@twitter.com/AnferneeOnamu" />
<meta name="twitter:site" content="@gadgetsafrica" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://gadgets-africa.com/#organization","name":"Gadgets Africa","url":"https://gadgets-africa.com/","sameAs":["https://www.facebook.com/gadgetsafrica/","https://www.instagram.com/gadgetsafrica/","https://www.linkedin.com/showcase/gadgets-africa/","https://www.youtube.com/channel/UCRJ61nOkisPdHz-yR2KwA4w","https://twitter.com/gadgetsafrica"],"logo":{"@type":"ImageObject","@id":"https://gadgets-africa.com/#logo","inLanguage":"en-GB","url":"","caption":"Gadgets Africa"},"image":{"@id":"https://gadgets-africa.com/#logo"}},{"@type":"WebSite","@id":"https://gadgets-africa.com/#website","url":"https://gadgets-africa.com/","name":"Gadgets Africa","description":"Reviews, Technology News and Everything Gadgets","publisher":{"@id":"https://gadgets-africa.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://gadgets-africa.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-GB"},{"@type":"ImageObject","@id":"https://gadgets-africa.com/2021/02/21/spinach-sending-emails/#primaryimage","inLanguage":"en-GB","url":"https://i1.wp.com/gadgets-africa.com/wp-content/uploads/2021/02/Untitled-design-9-1.jpg?fit=1920%2C1080&ssl=1","width":1920,"height":1080,"caption":"Spinach"},{"@type":"WebPage","@id":"https://gadgets-africa.com/2021/02/21/spinach-sending-emails/#webpage","url":"https://gadgets-africa.com/2021/02/21/spinach-sending-emails/","name":"Scientists are Teaching Spinach How To Send Emails","isPartOf":{"@id":"https://gadgets-africa.com/#website"},"primaryImageOfPage":{"@id":"https://gadgets-africa.com/2021/02/21/spinach-sending-emails/#primaryimage"},"datePublished":"2021-02-21T09:54:02+00:00","dateModified":"2021-02-21T09:54:02+00:00","description":"I love Spinach. So, you can imagine my shock when I heard that Spinach now has the capability to send emails. This experiment is part of a wider field of...","inLanguage":"en-GB","potentialAction":[{"@type":"ReadAction","target":["https://gadgets-africa.com/2021/02/21/spinach-sending-emails/"]}]},{"@type":"Article","@id":"https://gadgets-africa.com/2021/02/21/spinach-sending-emails/#article","isPartOf":{"@id":"https://gadgets-africa.com/2021/02/21/spinach-sending-emails/#webpage"},"author":{"@id":"https://gadgets-africa.com/#/schema/person/3ab590133763f22d96bc405b33d35ad4"},"headline":"Scientists are Teaching Spinach To Send Emails and Turning Them Into Human Hearts","datePublished":"2021-02-21T09:54:02+00:00","dateModified":"2021-02-21T09:54:02+00:00","mainEntityOfPage":{"@id":"https://gadgets-africa.com/2021/02/21/spinach-sending-emails/#webpage"},"commentCount":0,"publisher":{"@id":"https://gadgets-africa.com/#organization"},"image":{"@id":"https://gadgets-africa.com/2021/02/21/spinach-sending-emails/#primaryimage"},"keywords":"emails,Spinach","articleSection":"Editorial","inLanguage":"en-GB","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://gadgets-africa.com/2021/02/21/spinach-sending-emails/#respond"]}]},{"@type":["Person"],"@id":"https://gadgets-africa.com/#/schema/person/3ab590133763f22d96bc405b33d35ad4","name":"Anfernee Onamu","image":{"@type":"ImageObject","@id":"https://gadgets-africa.com/#personlogo","inLanguage":"en-GB","url":"https://gadgets-africa.com/wp-content/uploads/2020/11/IMG_20201112_170746_677.jpg","caption":"Anfernee Onamu"},"description":"I'm on a rollercoaster that only goes up","sameAs":["https://twitter.com/twitter.com/AnferneeOnamu"]}]}</script>

<link rel='dns-prefetch' href='//a.omappapi.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='preconnect' href='https://fonts.gstatic.com' crossorigin />
<link rel="alternate" type="application/rss+xml" title="Gadgets Africa &raquo; Feed" href="https://gadgets-africa.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Gadgets Africa &raquo; Comments Feed" href="https://gadgets-africa.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Gadgets Africa &raquo; Scientists are Teaching Spinach To Send Emails and Turning Them Into Human Hearts Comments Feed" href="https://gadgets-africa.com/2021/02/21/spinach-sending-emails/feed/" />

<script src="//www.googletagmanager.com/gtag/js?id=UA-132325730-1" type="text/javascript" data-cfasync="false"></script>
<script type="text/javascript" data-cfasync="false">
				var em_version = '6.6.0';
				var em_track_user = true;
				var em_no_track_reason = '';
				
								var disableStr = 'ga-disable-UA-132325730-1';

				/* Function to detect opted out users */
				function __gtagTrackerIsOptedOut() {
					return document.cookie.indexOf( disableStr + '=true' ) > - 1;
				}

				/* Disable tracking if the opt-out cookie exists. */
				if ( __gtagTrackerIsOptedOut() ) {
					window[disableStr] = true;
				}

				/* Opt-out function */
				function __gtagTrackerOptout() {
					document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
					window[disableStr] = true;
				}

				if ( 'undefined' === typeof gaOptout ) {
					function gaOptout() {
						__gtagTrackerOptout();
					}
				}
								window.dataLayer = window.dataLayer || [];
				if ( em_track_user ) {
					function __gtagTracker() {
						dataLayer.push( arguments );
					}
					__gtagTracker( 'js', new Date() );
					__gtagTracker( 'set', {
						'developer_id.dNDMyYj' : true,
						                    });
					__gtagTracker( 'config', 'UA-132325730-1', {
						forceSSL:true,anonymize_ip:true,					} );
										window.gtag = __gtagTracker;										(
						function () {
							/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
							/* ga and __gaTracker compatibility shim. */
							var noopfn = function () {
								return null;
							};
							var noopnullfn = function () {
								return null;
							};
							var Tracker = function () {
								return null;
							};
							var p = Tracker.prototype;
							p.get = noopfn;
							p.set = noopfn;
							p.send = noopfn;
							var __gaTracker = function () {
								var len = arguments.length;
								if ( len === 0 ) {
									return;
								}
								var f = arguments[len - 1];
								if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
									if ( 'send' === arguments[0] ) {
										if ( 'event' === arguments[1] ) {
											__gtagTracker( 'event', arguments[3], {
												'event_category': arguments[2],
												'event_label': arguments[4],
												'value': 1
											} );
											return;
										}
										if ( 'undefined' !== typeof ( arguments[1].hitType ) ) {
											var hitDetails = {};
											var gagtag_map = {
												'eventCategory': 'event_category',
												'eventAction': 'event_action',
												'eventLabel': 'event_label',
												'eventValue': 'event_value',
												'nonInteraction': 'non_interaction',
												'timingCategory': 'event_category',
												'timingVar': 'name',
												'timingValue': 'value',
												'timingLabel': 'event_label',
											};
											var gaKey;
											for ( gaKey in gagtag_map ) {
												if ( 'undefined' !== typeof arguments[1][gaKey] ) {
													hitDetails[gagtag_map[gaKey]] = arguments[1][gaKey];
												}
											}
											var action = 'timing' === arguments[1].hitType ? 'timing_complete' : arguments[1].eventAction;
											__gtagTracker( 'event', action, hitDetails );
										}
									}
									return;
								}
								try {
									f.hitCallback();
								} catch ( ex ) {
								}
							};
							__gaTracker.create = function () {
								return new Tracker();
							};
							__gaTracker.getByName = noopnullfn;
							__gaTracker.getAll = function () {
								return [];
							};
							__gaTracker.remove = noopfn;
							__gaTracker.loaded = true;
							window['__gaTracker'] = __gaTracker;
						}
					)();
									} else {
										console.log( "" );
					( function () {
						function __gtagTracker() {
							return null;
						}
						window['__gtagTracker'] = __gtagTracker;
						window['gtag'] = __gtagTracker;
					} )();
									}
			</script>

<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/gadgets-africa.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://c0.wp.com/c/5.3.6/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='emailoctopus_admin_frontend_styles-css' href='https://gadgets-africa.com/wp-content/plugins/emailoctopus/css/frontend.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='fontawsome-css-css' href='https://gadgets-africa.com/wp-content/plugins/accesspress-social-login-lite/css/font-awesome/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='apsl-frontend-css-css' href='https://gadgets-africa.com/wp-content/plugins/accesspress-social-login-lite/css/frontend.css' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css' href='https://gadgets-africa.com/wp-content/plugins/contact-form-7/includes/css/styles.css' type='text/css' media='all' />
<link rel='stylesheet' id='fvp-frontend-css' href='https://gadgets-africa.com/wp-content/plugins/featured-video-plus/styles/frontend.css' type='text/css' media='all' />
<link rel='stylesheet' id='bkswcss-css' href='https://gadgets-africa.com/wp-content/plugins/tnm-shortcode/css/shortcode.css' type='text/css' media='all' />
<link rel='stylesheet' id='twenty20-style-css' href='https://gadgets-africa.com/wp-content/plugins/twenty20/assets/css/twenty20.css' type='text/css' media='all' />
<link rel='stylesheet' id='wpsr_main_css-css' href='https://gadgets-africa.com/wp-content/plugins/wp-socializer/public/css/wpsr.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wpsr_fa_icons-css' href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='exactmetrics-popular-posts-style-css' href='https://gadgets-africa.com/wp-content/plugins/google-analytics-dashboard-for-wp/assets/css/frontend.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='thenextmag_vendors-css' href='https://gadgets-africa.com/wp-content/themes/the-next-mag/css/vendors.css' type='text/css' media='all' />
<link rel='stylesheet' id='thenextmag-style-css' href='https://gadgets-africa.com/wp-content/themes/the-next-mag/css/style.css' type='text/css' media='all' />
<style id='thenextmag-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='emailoctopus_frontend-css' href='https://gadgets-africa.com/wp-content/plugins/emailoctopus/css/frontend.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='heateor_sss_frontend_css-css' href='https://gadgets-africa.com/wp-content/plugins/sassy-social-share/public/css/sassy-social-share-public.css' type='text/css' media='all' />
<link rel='stylesheet' id='heateor_sss_sharing_default_svg-css' href='https://gadgets-africa.com/wp-content/plugins/sassy-social-share/admin/css/sassy-social-share-svg.css' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css' href='https://gadgets-africa.com/wp-content/plugins/tablepress/css/default.min.css' type='text/css' media='all' />
<link rel="preload" as="style" href="https://fonts.googleapis.com/css?family=Rubik:300,400,500,700,900,300italic,400italic,500italic,700italic,900italic&#038;display=swap&#038;ver=1604671145" /><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Rubik:300,400,500,700,900,300italic,400italic,500italic,700italic,900italic&#038;display=swap&#038;ver=1604671145" media="print" onload="this.media='all'"><noscript><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Rubik:300,400,500,700,900,300italic,400italic,500italic,700italic,900italic&#038;display=swap&#038;ver=1604671145" /></noscript><link rel='stylesheet' id='jetpack_css-css' href='https://c0.wp.com/p/jetpack/8.7.1/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var exactmetrics_frontend = {"js_events_tracking":"true","download_extensions":"zip,mp3,mpeg,pdf,docx,pptx,xlsx,rar","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/gadgets-africa.com","hash_tracking":"false","ua":"UA-132325730-1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://gadgets-africa.com/wp-content/plugins/google-analytics-dashboard-for-wp/assets/js/frontend-gtag.min.js' defer='defer'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.6/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.6/wp-includes/js/jquery/jquery-migrate.min.js' defer='defer'></script>
<script type='text/javascript' src='https://gadgets-africa.com/wp-content/plugins/accesspress-social-login-lite/js/frontend.js' defer='defer'></script>
<script type='text/javascript' src='https://gadgets-africa.com/wp-content/plugins/featured-video-plus/js/jquery.fitvids.min.js' defer='defer'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var fvpdata = {"ajaxurl":"https:\/\/gadgets-africa.com\/wp-admin\/admin-ajax.php","nonce":"73c4c77d9d","fitvids":"1","dynamic":"","overlay":"","opacity":"0.75","color":"b","width":"640"};
/* ]]> */
</script>
<script type='text/javascript' src='https://gadgets-africa.com/wp-content/plugins/featured-video-plus/js/frontend.min.js' defer='defer'></script>
<link rel='https://api.w.org/' href='https://gadgets-africa.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://gadgets-africa.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://gadgets-africa.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.3.6" />
<link rel='shortlink' href='https://wp.me/paAUjP-5CP' />
<link rel="alternate" type="application/json+oembed" href="https://gadgets-africa.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fgadgets-africa.com%2F2021%2F02%2F21%2Fspinach-sending-emails%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://gadgets-africa.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fgadgets-africa.com%2F2021%2F02%2F21%2Fspinach-sending-emails%2F&#038;format=xml" />
<meta name="framework" content="Redux 4.1.24" /><script type="text/javascript">
(function(h,e,a,t,m,p) {
m=e.createElement(a);m.async=!0;m.src=t;
p=e.getElementsByTagName(a)[0];p.parentNode.insertBefore(m,p);
})(window,document,'script','https://u.heatmap.it/log.js');
</script>
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<style type='text/css'>img#wpstats{display:none}</style> <style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
<link rel="icon" href="https://i0.wp.com/gadgets-africa.com/wp-content/uploads/2019/01/cropped-GA-favicon-1.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/gadgets-africa.com/wp-content/uploads/2019/01/cropped-GA-favicon-1.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i0.wp.com/gadgets-africa.com/wp-content/uploads/2019/01/cropped-GA-favicon-1.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/gadgets-africa.com/wp-content/uploads/2019/01/cropped-GA-favicon-1.png?fit=270%2C270&#038;ssl=1" />
<style type="text/css" id="wp-custom-css">
				.issuuembed.issuu-isrendered {
    width: 100%!important;
    height: auto!important;
}

  @media only screen and (max-width: 600px) {
      span.embed-youtube iframe {
 
    max-height: 300px !important;
}

}
			</style>
<style id="tnm_option-dynamic-css" title="dynamic-css" class="redux-options-output">body{font-family:Rubik,Arial, Helvetica, sans-serif;font-display:swap;}.post__title, .entry-title, h1, h2, h3, h4, h5, h6, .h1, .h2, .h3, .h4, .h5, .h6, .text-font-primary, .social-tile__title, .widget_recent_comments .recentcomments > a, .widget_recent_entries li > a, .modal-title.modal-title, .author-box .author-name a, .comment-author, .widget_calendar caption, .widget_categories li>a, .widget_meta ul, .widget_recent_comments .recentcomments>a, .widget_recent_entries li>a, .widget_pages li>a{font-family:Rubik,Arial, Helvetica, sans-serif;font-display:swap;}.text-font-secondary, .block-heading__subtitle, .widget_nav_menu ul, .navigation .sub-menu, .typography-copy blockquote, .comment-content blockquote{font-family:Rubik,Arial, Helvetica, sans-serif;font-display:swap;}.mobile-header-btn, .navigation-bar-btn, .navigation, .menu, .mnmd-mega-menu__inner > .sub-menu > li > a, .meta-text, a.meta-text, .meta-font, a.meta-font, .text-font-tertiary, .block-heading, .block-heading__title, .block-heading-tabs, .block-heading-tabs > li > a, input[type="button"]:not(.btn), input[type="reset"]:not(.btn), input[type="submit"]:not(.btn), .btn, label, .category-tile__name, .page-nav, .post-score, .post-score-hexagon .post-score-value, .post__cat, a.post__cat, .entry-cat, a.entry-cat, .read-more-link, .post__meta, .entry-meta, .entry-author__name, a.entry-author__name, .comments-count-box, .widget__title-text, .mnmd-widget-indexed-posts-a .posts-list > li .post__thumb:after, .mnmd-widget-indexed-posts-b .posts-list > li .post__title:after, .mnmd-widget-indexed-posts-c .list-index, .social-tile__count, .widget_recent_comments .comment-author-link, .mnmd-video-box__playlist .is-playing .post__thumb:after, .mnmd-posts-listing-a .cat-title, .mnmd-news-ticker__heading, .page-heading__title, .post-sharing__title, .post-sharing--simple .sharing-btn, .entry-action-btn, .entry-tags-title, .post-categories__title, .posts-navigation__label, .comments-title, .comments-title__text, .comments-title .add-comment, .comment-metadata, .comment-metadata a, .comment-reply-link, .comment-reply-title, .countdown__digit, .modal-title, .comment-reply-title, .comment-meta, .comment .reply, .wp-caption, .gallery-caption, .widget-title, .btn, .navigation, .logged-in-as, .countdown__digit, .mnmd-widget-indexed-posts-a .posts-list>li .post__thumb:after, .mnmd-widget-indexed-posts-b .posts-list>li .post__title:after, .mnmd-widget-indexed-posts-c .list-index, .mnmd-horizontal-list .index, .mnmd-pagination, .mnmd-pagination--next-n-prev .mnmd-pagination__label{font-family:Rubik,Arial, Helvetica, sans-serif;font-display:swap;}.header-main{padding-top:40px;padding-bottom:40px;}</style>
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/21802685407/Inner300*600_GA', [300, 600], 'div-gpt-ad-1594287254583-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-132325730-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());
  gtag('config', 'UA-132325730-1');
</script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>  (adsbygoogle = window.adsbygoogle || []).push({  
  google_ad_client: "ca-pub-4078978776513730",   
   enable_page_level_ads: true 
    });
  </script>

<script type="application/ld+json">
{
          "@context": "http://schema.org",
          "@type": "NewsArticle",
          "mainEntityOfPage": {
            "@type": "WebPage",
            "@id": "https://gadgets-africa.com/2021/02/21/spinach-sending-emails/"
          },
          "headline": "Scientists are Teaching Spinach To Send Emails and Turning Them Into Human Hearts",
          "image": [
            "https://i1.wp.com/gadgets-africa.com/wp-content/uploads/2021/02/Untitled-design-9-1.jpg?fit=1920%2C1080&#038;ssl=1"
           ],
          "datePublished": "2021-02-21T12:54:02+00:00",
          "dateModified": "2021-02-21T12:54:02+03:00",
          "author": {
            "@type": "Person",
            "name": "Anfernee Onamu"
          },
           "publisher": {
            "@type": "Organization",
            "name": "Gadgets Africa",
            "logo": {
              "@type": "ImageObject",
              "url": "https://i2.wp.com/gadgets-africa.com/wp-content/uploads/2019/01/gadget-header-logo.png?fit=300%2C81&#038;ssl=1"
            }
          },
          "description": "In 2021 there will be flying cars.

2021: Mboga imeenda shule"
        }
        </script>

<script>
!function(f,b,e,v,n,t,s)
{if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};
if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];
s.parentNode.insertBefore(t,s)}(window,document,'script',
'https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '269425903952511');
fbq('track', 'PageView');
</script>
<noscript>
<img height="1" width="1"
src="https://www.facebook.com/tr?id=269425903952511&ev=PageView
&noscript=1"/>
</noscript>



<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/21802685407/GAHPDuplicateadunit728', [728, 90], 'div-gpt-ad-1608615723051-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
var mapping1 = googletag.sizeMapping().
addSize([800,90], [728, 90]).
addSize([0, 0], [300, 37]).
build();
    googletag.defineSlot('/21802685407/HP_Responsive', [[300, 37], [728, 90]], 'div-gpt-ad-1593260557909-0').addService(googletag.pubads());
    googletag.defineSlot('/21802685407/HP_Responsive_2', [300, 250], 'div-gpt-ad-1593260596647-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>


<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/21802685407/300*250sidebar', [300, 250], 'div-gpt-ad-1605697385387-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<script data-ad-client="ca-pub-3549148798608953" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/21802685407/Tunda', [768, 1024], 'div-gpt-ad-1582095883812-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>


<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/21802685407/31Dec300*250MobileArticlead', [300, 250], 'div-gpt-ad-1609415631390-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/21802685407/31Dec', [300, 250], 'div-gpt-ad-1609404095622-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/21802685407/31Decsecondad', [300, 250], 'div-gpt-ad-1609405607905-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/21802685407/31Dec728*90', [728, 90], 'div-gpt-ad-1609406279792-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/21802685407/31DecSecondAD728*90', [728, 90], 'div-gpt-ad-1609407621035-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/21802685407/31DecArticleadunit300*250', [300, 250], 'div-gpt-ad-1609408301108-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/21802685407/HpMobileadunit', [300, 37], 'div-gpt-ad-1609309353218-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/21802685407/300*250//', [300, 250], 'div-gpt-ad-1605697776061-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>


<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-5JNN4Q7');</script>


<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/21802685407/728*90////', [728, 90], 'div-gpt-ad-1608735632220-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
</head>
<style type="text/css">
     .single.single-post .theiaStickySidebar .post__text-inner .media {
    display: block!important;
}
</style>
<body data-rsssl=1 class="post-template-default single single-post postid-21627 single-format-standard header-5">

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-5JNN4Q7"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<div class="site-wrapper">
<style type="text/css">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</style>
<script>
 jQuery(function() {
    var header = jQuery("#mainHead");
    jQuery(window).scroll(function() {    
        var scroll = jQuery(window).scrollTop();
        if (scroll >= 100) {
            header.addClass("fixed-top");
        } else {
            header.removeClass("fixed-top");
        }
    });
});
</script>
<section class="logo-section">
<div class="container text-center">
<h1 class="mb-0"><a href="https://gadgets-africa.com">
<img src="https://gadgets-africa.com/wp-content/uploads/2019/01/gadget-header-logo.png" alt="logo" />
</a></h1>
</div>
</section>
<header class="site-header site-header--skin-2" id="mainHead">

<div id="mnmd-mobile-header" class="mobile-header visible-xs visible-sm  mobile-header--inverse">
<div class="mobile-header__inner mobile-header__inner--flex">

<div class="header-branding header-branding--mobile mobile-header__section text-left">
<div class="header-logo header-logo--mobile flexbox__item text-left">
<a href="https://gadgets-africa.com">
<img src="https://gadgets-africa.com/wp-content/uploads/2019/01/gadget-header-logo.png" alt="logo" />
</a>
</div>
</div>

<div class="mobile-header__section text-right">

<a href="" data-toggle="modal" data-target="#exampleModalCenter" target="_blank" class="btn btn-primary btn-xs">Subscribe
</a>
<button type="submit" class="mobile-header-btn js-search-dropdown-toggle">
<span class="hidden-xs">Search</span><i class="mdicon mdicon-search mdicon--last hidden-xs"></i><i class="mdicon mdicon-search visible-xs-inline-block"></i>
</button>
<a href="#mnmd-offcanvas-mobile" class="offcanvas-menu-toggle mobile-header-btn js-mnmd-offcanvas-toggle">
<span class="hidden-xs">Menu</span><i class="mdicon mdicon-menu mdicon--last hidden-xs"></i><i class="mdicon mdicon-menu visible-xs-inline-block"></i>
</a>
</div>
</div>
</div>

<nav class="navigation-bar navigation-bar--fullwidth hidden-xs hidden-sm js-sticky-header-holder  navigation-bar--inverse">
<div class="container">
<div class="navigation-bar__inner">
<div class="navigation-bar__section">
<div class="site-logo header-logo">
<a href="https://gadgets-africa.com">

<img src="https://gadgets-africa.com/wp-content/uploads/2019/01/gadget-header-logo.png" alt="logo" />
 
</a>
</div>
</div>
<div class="navigation-wrapper navigation-bar__section js-priority-nav">
<div id="main-menu" class="menu-newmain_menu-container"><ul id="menu-newmain_menu" class="navigation navigation--main navigation--inline"><li id="menu-item-10340" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10340 menu-item-cat-7"><a href="https://gadgets-africa.com/category/software/apps/">Apps</a></li>
<li id="menu-item-21344" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21344 menu-item-cat-212"><a href="https://gadgets-africa.com/category/more/cars/">Automobiles</a></li>
<li id="menu-item-10314" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10314 menu-item-cat-587"><a href="https://gadgets-africa.com/category/gaming/">Gaming</a></li>
<li id="menu-item-10318" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10318 menu-item-cat-209"><a href="https://gadgets-africa.com/category/home-tech/">Home Electronics</a></li>
<li id="menu-item-18381" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18381 menu-item-cat-207"><a href="https://gadgets-africa.com/category/mobile/laptops/">Laptops</a></li>
<li id="menu-item-21345" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21345 menu-item-cat-13"><a href="https://gadgets-africa.com/category/more/lists/">Lists</a></li>
<li id="menu-item-18382" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18382 menu-item-cat-206"><a href="https://gadgets-africa.com/category/mobile/smartphones/">Smartphones</a></li>
<li id="menu-item-21346" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21346 menu-item-cat-1275"><a href="https://gadgets-africa.com/category/more/governance/">Tech &#038; Governance</a></li>
</ul></div> </div>

<div class="navigation-bar__section lwa lwa-template-modal test5">
<a href="" data-toggle="modal" data-target="#exampleModalCenter" target="_blank" class="btn btn-primary btn-xs">Subscribe
</a>
<button type="submit" class="navigation-bar-btn js-search-dropdown-toggle"><i class="mdicon mdicon-search"></i></button>
</div>
</div>
<div id="header-search-dropdown" class="header-search-dropdown ajax-search is-in-navbar js-ajax-search">
<div class="container container--narrow">
<form class="search-form search-form--horizontal" method="get" action="https://gadgets-africa.com/">
<div class="search-form__input-wrap">
<input type="text" name="s" class="search-form__input" placeholder="Search" value="" />
</div>
<div class="search-form__submit-wrap">
<button type="submit" class="search-form__submit btn btn-primary">Search</button>
</div>
</form>
<div class="search-results">
<div class="typing-loader"></div>
<div class="search-results__inner"></div>
</div>
</div>
</div> </div>
</nav>
</header>

<style type="text/css">
.header-sub .custom-button{box-shadow: none;border: none;text-transform: uppercase;}
    .header-sub .email-octopus-form-row input {
    width: 100%;
    padding: 8px;
    height: 45px;
    border: none;
       max-width: 560px;
       border-radius: 0px;
}
.header-sub .email-octopus-form-row-subscribe button {
    background-color: #5312c7;
border-radius: 2px
}
.header-sub .email-octopus-form-row {
    margin-bottom: 4px;
}
.header-sub .email-octopus-form-row-subscribe {
    margin-top: 0px;
}
 .header-sub .email-octopus-form-row-subscribe button {
    width: 100%;
    height: 45px;
        max-width: 560px;
        text-transform: uppercase;
}
    .header-sub button.btn-primary.custom-button {
    width: 100%;
    height: 50px;
    color:#fff!important;
        max-width: 560px;
        border-radius: 5px
}
  .facebook button.btn-primary.custom-button {
    background-color:#1e6dca
}
 .twitter button.btn-primary.custom-button {
    background-color:#3288da
}
 .youtube button.btn-primary.custom-button {
    background-color:#eb160e
}
 .whatapp button.btn-primary.custom-button {
    background-color:#0fa136
}
 .tele button.btn-primary.custom-button {
    background-color:#36b4dd
}
.octopus {
    background-color: black;
    margin: 0 45px;
    border: 5px solid #f3e0e0;
}
.header-sub .modal-content {
    background-color: #353232!important;
    color:#fff;
}
.header-sub .octopus p.ft {
    color: #878181;
}
.header-sub h4.modal-title {
    font-size: 14px;
    text-transform: inherit;
    color: #d2d0d8;
}
.header-sub p.des{
  font-size: 16px;
text-transform: inherit;
margin-bottom: 0px;
margin-top: 10px;
color: #d5cdcd;
}
@media screen and (max-width: 768px) {
  .octopus {
       margin: 0 auto;
  }
}
</style>
<div class="modal fade header-sub" id="exampleModalCenter" tabindex="-1" role="dialog" aria-labelledby="exampleModalCenterTitle" aria-hidden="true">
<div class="modal-dialog modal-dialog-centered" role="document">
<div class="modal-content">
<div class="modal-header">
<div class="col-md-12 text-center pt-3">
<h4 class="modal-title py-3">want to get all the latest from Gadgets Africa on your favourite platfoms?</h4>
<p class="des">Subscribe today and never miss out!</p>
</div>
<div class="">
<button type="button " class="close" data-dismiss="modal" aria-label="Close">
<span aria-hidden="true">&times;</span>
</button>
</div>
</div>
<div class="modal-body">
<div class="row px-0 px-md-3 text-center">
<div class="col-md-12 col-12 p-2">
<div class="">
<div class="optin-types optin-customization"><button class="btn-primary custom-button" onclick="truepush.subscribeUserVapid()" style="color:#fff;background-color:#1e6dca"><i class="far fa-bell"></i> Push Notifications</button></div>
</div>
</div>
<div class="col-md-12 col-12 p-2">
<a href="https://www.facebook.com/gadgetsafrica" target="_blank">
<div class="facebook">
<button class="btn-primary custom-button"><i class="fab fa-facebook"></i> Facebook</button>
</div>
</div>
<div class="col-md-12 col-12 p-2">
<a href="https://twitter.com/gadgetsafrica" target="_blank">
<div class="twitter">
<button class="btn-primary custom-button"><i class="fab fa-twitter"></i> Twitter</button>
</div>
</div>
<div class="col-md-12 col-12 p-2">
<a href="https://www.youtube.com/channel/UCWWoyj-9s7Oa7yUHLTcKMPg" target="_blank">
<div class="youtube">
<button class="btn-primary custom-button"><i class="fab fa-youtube"></i> Youtube</button>
</div>
</a></div>
<div class="col-md-12 col-12 p-2">
<a href="https://bit.ly/GadgetsAfricaWhatsApp" target="_blank">
<div class="whatapp">
<button class="btn-primary custom-button"><i class="fab fa-whatsapp"></i> Whatsapp</button>
</div>
</a></div>
<div class="col-md-12 col-12 p-2">
<a href="https://t.me/gadgetsafrica " target="_blank">
<div class="tele">
<button class="btn-primary custom-button"><i class="fab fa-telegram"></i> Telegram</button>
</div>
</a> </div>
<div class="col-md-12 col-12 p-2">
<link rel="stylesheet" href="https://emailoctopus.com/bundles/emailoctopuslist/css/formEmbed.css">
<div class="octopus">
<div class="email-octopus-form-wrapper">

<form method="post" action="https://emailoctopus.com/lists/1debe9e4-01c9-11e9-a3c9-06b79b628af2/members/embedded/1.3s/add" class="email-octopus-form" data-sitekey="6LdYsmsUAAAAAPXVTt-ovRsPIJ_IVhvYBBhGvRV6">
<div class="email-octopus-form-row">
<input id="field_0" name="field_0" type="email" placeholder="Enter your email here...">
</div>
<div class="email-octopus-form-row-hp" aria-hidden="true">

<input type="text" name="hp1debe9e4-01c9-11e9-a3c9-06b79b628af2" tabindex="-1" autocomplete="nope">
</div>
<div class="email-octopus-form-row-subscribe">
<input type="hidden" name="successRedirectUrl" value="">
<button type="submit">Join The Community!</button>
</div>
</form>
<p class="email-octopus-success-message"></p>
<p class="email-octopus-error-message"></p>
<p class="ft pt-2">We do not sell or share your information with anyone.</p>

</div>
<script src="https://emailoctopus.com/bundles/emailoctopuslist/js/1.4/recaptcha.js"></script>

</div>
</div>
</div>
</div>
</div>
</div>
</div>
<link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/bootstrap/4.0.0/css/bootstrap.min.css">
 <style type="text/css">
      .singletop-banner{
    margin: 20px 10px 0 10px;
}
/*.dfph-ads iframe {
  min-height: 90px !important;
  height: 90px;
}*/
#google_center_div {
    display: block!important;
    vertical-align: middle;
}

/*.dfp-ads{
    max-width: 728px;
    margin: 0 auto;
}*/
.single-body.entry-content.typography-copy a {
   color: #E74C3C;
}
.des-dfpad iframe {
    width: 100%;
    min-height: inherit;
}
iframe {
    min-height: auto!important;
}
@media screen and (max-width: 600px) {
    .dfp-ads iframe {
width: 300px !important;
min-height: 0px!important;
 }  
 .dfp-ads .ads-2{
margin:0 auto;
width: 300px;

 }
    
.dfph-ads iframe {
    min-height: 40px !important;
    height: 40px;
}
.dfps-adsf {
    max-width: 320px;
}

.mob-sidebar-dfpad{
     max-width:300px;
    margin: 0 auto; 

}
}
</style>
<div class="blogpost-wrapper">
<div class="container">
<div class="row mt-4">
<div class="col-md-12 text-center">
<div class="dfp-ads d-none d-md-block mb-3">

<div id='div-gpt-ad-1608735632220-0' style='width: 728px; height: 90px;'>
<script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1608735632220-0'); });
  </script>
</div>
</div>
<div class="dfp-ads d-block d-md-none text-center mb-3">

<div id='div-gpt-ad-1609309353218-0' style='width: 100%; height: 37px;'>
<script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1609309353218-0'); });
  </script>
</div>
</div>
</div>
</div>
</div></div>
<div class="site-content single-entry single-entry--no-sidebar single-entry--billboard-floorfade">
<div class="mnmd-block mnmd-block--fullwidth mnmd-block--contiguous single-billboard">
<div class="background-img hidden-xs hidden-sm" style="background-image: url('https://i1.wp.com/gadgets-africa.com/wp-content/uploads/2021/02/Untitled-design-9-1.jpg?resize=1920%2C1080&#038;ssl=1');"></div>
<div class="background-img hidden-md hidden-lg" style="background-image: url('https://i1.wp.com/gadgets-africa.com/wp-content/uploads/2021/02/Untitled-design-9-1.jpg?resize=1200%2C900&#038;ssl=1');"></div>
<div class="single-billboard__inner">
<header class="single-header single-header--center">
<div class="container">
<div class="single-header__inner inverse-text">
<a class="cat-8 post__cat post__cat--bg cat-theme-bg" href="https://gadgets-africa.com/category/more/editorial/">Editorial</a> <h1 class="entry-title entry-title--lg">Scientists are Teaching Spinach To Send Emails and Turning Them Into Human Hearts</h1>
<div class="entry-teaser hidden-xs">
In 2021 there will be flying cars.
2021: Mboga imeenda shule </div>

<div class="entry-meta singlepage">
<span class="entry-author entry-author--with-ava">
<img src="https://i2.wp.com/gadgets-africa.com/wp-content/uploads/2020/11/IMG_20201112_170746_677.jpg?fit=20%2C34&amp;ssl=1" width="20" height="34" alt="Anfernee Onamu" class="avatar avatar-34 wp-user-avatar wp-user-avatar-34 alignnone photo jetpack-lazy-image" data-lazy-src="https://i2.wp.com/gadgets-africa.com/wp-content/uploads/2020/11/IMG_20201112_170746_677.jpg?fit=20%2C34&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img src="https://i2.wp.com/gadgets-africa.com/wp-content/uploads/2020/11/IMG_20201112_170746_677.jpg?fit=20%2C34&ssl=1" width="20" height="34" alt="Anfernee Onamu" class="avatar avatar-34 wp-user-avatar wp-user-avatar-34 alignnone photo" /></noscript>&nbsp; By <a class="entry-author__name" title="Posts by Anfernee Onamu" rel="author" href="https://gadgets-africa.com/author/elphas-onamu/">Anfernee Onamu</a> </span>
<time class="time published" datetime="2021-02-21T12:54:02+00:00" title="February 21, 2021 at 12:54 pm"><i class="mdicon mdicon-schedule"></i>6 hours ago</time></div> </div>
</div>
</header>
</div>
</div>
<div class="mnmd-block mnmd-block--fullwidth single-entry-wrap">
<article class="mnmd-block post--single post-21627 post type-post status-publish format-standard has-post-thumbnail hentry category-editorial tag-emails tag-spinach">
<div class="single-content">
<div class="container container--narrow">
<div class="entry-interaction entry-interaction--horizontal">
<div class="entry-interaction__left">
<div class="post-sharing post-sharing--simple">
<ul>
</ul>
</div>
</div>
<div class="entry-interaction__right">
<a href="#comments" class="comments-count entry-action-btn" data-toggle="tooltip" data-placement="top" title="0 Comments"><i class="mdicon mdicon-chat_bubble"></i><span>0</span></a> </div>
</div>
<div class="entry-teaser visible-xs">
In 2021 there will be flying cars.
2021: Mboga imeenda shule </div>
<div class="single-body single-body--wide entry-content typography-copy">
<div class="wp-socializer wpsr-share-icons " data-lg-action="show" data-sm-action="show" data-sm-width="768"><div class="wpsr-si-inner"><div class="socializer sr-popup sr-40px sr-circle sr-zoom sr-pad"><span class="sr-facebook sr-text-in"><a rel="nofollow" href="https://www.facebook.com/share.php?u=https://gadgets-africa.com/2021/02/21/spinach-sending-emails/" target="_blank" title="Share this on Facebook" style="color: #ffffff"><i class="fa fa-facebook-f"></i><span class="text">Share This!</span></a></span>
<span class="sr-twitter"><a rel="nofollow" href="https://twitter.com/intent/tweet?text=Scientists+are+Teaching+Spinach+To+Send+Emails+and+Turning+Them+Into+Human+Hearts%20-%20https://gadgets-africa.com/2021/02/21/spinach-sending-emails/%20@gadgetsafrica" target="_blank" title="Tweet this !" style="color: #ffffff"><i class="fa fa-twitter"></i></a></span>
<span class="sr-whatsapp"><a rel="nofollow" href="https://api.whatsapp.com/send?text=Scientists+are+Teaching+Spinach+To+Send+Emails+and+Turning+Them+Into+Human+Hearts%20https://gadgets-africa.com/2021/02/21/spinach-sending-emails/" target="_blank" title="WhatsApp" style="color: #ffffff" data-mobile="whatsapp://send?text=Scientists+are+Teaching+Spinach+To+Send+Emails+and+Turning+Them+Into+Human+Hearts%20-%20https://gadgets-africa.com/2021/02/21/spinach-sending-emails/"><i class="fa fa-whatsapp"></i></a></span></div></div></div><p>I love spinach. In my opinion, it&#8217;s the perfect meal combination. Plate some <em>Ugali, beef stew, topped off with guacamole (Avocado)</em> and you have a direct route to my heart. It&#8217;s basically a staple food from where I come from<em>. </em>So, you can imagine my shock when I heard that Spinach now has the capability to send emails.</p>
<p>Fun factoid, that&#8217;s not all. Scientists are also turning them into beating heart cells. I know it is a special vegetable but this is not what I had in mind.</p>
<div class="whats-img d-md-block d-none text-center mb-3">
<div id="div-gpt-ad-1609408301108-0" style="width: 300px; height: 250px; margin: 0 0 0 120px;">
<script>
    googletag.cmd.push(function() { googletag.display("div-gpt-ad-1609408301108-0"); });
  </script>
</div>
</div>
<div class="whats-img d-block d-md-none text-center mb-3">
<div id="div-gpt-ad-1609415631390-0" style="width: 300px; height: 250px; margin: 0 0 0 25px;">
<script>
    googletag.cmd.push(function() { googletag.display("div-gpt-ad-1609415631390-0"); });
  </script>
</div>
</div>
<h3>2021 Future Tech: Spinach Sending Emails</h3>
<p>This experiment is part of a wider field of research that involves engineering electronic components and systems into plants. The technology is known as “plant nano bionics”. This is effectively the process of giving plants new abilities. <em>(No not like the X-Men)</em></p><div class="sigl-ads py-2">
<a target="_blank" href="https://t.me/gadgetsafrica"><img class="img-fluid width-100 whats-app jetpack-lazy-image" src="https://i0.wp.com/gadgets-africa.com/wp-content/themes/the-next-mag/img/telegram.png?w=1200&#038;ssl=1" data-recalc-dims="1" data-lazy-src="https://i0.wp.com/gadgets-africa.com/wp-content/themes/the-next-mag/img/telegram.png?w=1200&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="img-fluid width-100 whats-app" src="https://i0.wp.com/gadgets-africa.com/wp-content/themes/the-next-mag/img/telegram.png?w=1200&#038;ssl=1" data-recalc-dims="1"></noscript></a>
</div>
<p>Through nanotechnology, <a href="https://www.nature.com/articles/nmat4771.epdf"><strong>engineers at MIT</strong></a> in the US are transforming spinach into sensors capable of detecting explosive materials. When the spinach roots detect the presence of compounds often found in explosives like landmines in groundwater,  the plants emit a signal. The signal is read by an infrared camera and then sends an email alert to the scientists.</p>
<h5>Why Spinach?</h5>
<p>Well, speaking to <em><a href="https://www.euronews.com/living/2021/02/01/scientists-have-taught-spinach-to-send-emails-and-it-could-warn-us-about-climate-change">EuroNews</a>,</em> Professor Michael Strano, leading the research says that</p>
<blockquote><p>“Because of the vast amount of data plants absorb from their surroundings, they are in the perfect position to monitor ecological changes. They have an extensive root network in the soil and are constantly sampling groundwater. They have a way to self-power the transport of that water up into the leaves.”</p></blockquote>
<p>This makes them a prime candidate for this experiment.</p>
<div style="clear:both; margin-top:0em; margin-bottom:1em;"><a href="https://gadgets-africa.com/2021/01/07/landlords-to-conduct-background-checks/" target="_self" class="u906615fe3a526306f1d8d0eada0bb066"><style> .u906615fe3a526306f1d8d0eada0bb066 { padding:0px; margin: 0; padding-top:1em!important; padding-bottom:1em!important; width:100%; display: block; font-weight:bold; background-color:#FFFFFF; border:0!important; border-left:4px solid #FFFFFF!important; box-shadow: 0 1px 2px rgba(0, 0, 0, 0.17); -moz-box-shadow: 0 1px 2px rgba(0, 0, 0, 0.17); -o-box-shadow: 0 1px 2px rgba(0, 0, 0, 0.17); -webkit-box-shadow: 0 1px 2px rgba(0, 0, 0, 0.17); text-decoration:none; } .u906615fe3a526306f1d8d0eada0bb066:active, .u906615fe3a526306f1d8d0eada0bb066:hover { opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; text-decoration:none; } .u906615fe3a526306f1d8d0eada0bb066 { transition: background-color 250ms; webkit-transition: background-color 250ms; opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; } .u906615fe3a526306f1d8d0eada0bb066 .ctaText { font-weight:bold; color:#2980B9; text-decoration:none; font-size: 16px; } .u906615fe3a526306f1d8d0eada0bb066 .postTitle { color:#E74C3C; text-decoration: underline!important; font-size: 16px; } .u906615fe3a526306f1d8d0eada0bb066:hover .postTitle { text-decoration: underline!important; } </style><div style="padding-left:1em; padding-right:1em;"><span class="ctaText">Check This Out:</span>&nbsp; <span class="postTitle">Government Agency Goes After Tenants' Private Phone and Email Details</span></div></a></div><h5>What Does The Future hold for Spinach Now?</h5>
<p>Professor Strano and other scientists now believe that spinach could be used to help warn researchers about pollution and other environmental conditions.</p>
<p>“Plants are very environmentally responsive,” Strano says. “They know that there is going to be a drought long before we do. They can detect small changes in the properties of soil and water potential. If we tap into those chemical signalling pathways, there is a wealth of information to access.”</p>
<p>So next time you&#8217;re eating spinach, make sure it knows how special it is. As for transforming Spinach into a heart cell, you&#8217;ll have to watch that here.</p>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' width='1200' height='675' src='https://www.youtube.com/embed/x4KS6NyFo3Y?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>
<div class="wp-socializer wpsr-share-icons " data-lg-action="show" data-sm-action="show" data-sm-width="768"><div class="wpsr-si-inner"><div class="socializer sr-popup sr-40px sr-circle sr-zoom sr-pad"><span class="sr-facebook sr-text-in"><a rel="nofollow" href="https://www.facebook.com/share.php?u=https://gadgets-africa.com/2021/02/21/spinach-sending-emails/" target="_blank" title="Share this on Facebook" style="color: #ffffff"><i class="fa fa-facebook-f"></i><span class="text">Share This!</span></a></span>
<span class="sr-twitter"><a rel="nofollow" href="https://twitter.com/intent/tweet?text=Scientists+are+Teaching+Spinach+To+Send+Emails+and+Turning+Them+Into+Human+Hearts%20-%20https://gadgets-africa.com/2021/02/21/spinach-sending-emails/%20@gadgetsafrica" target="_blank" title="Tweet this !" style="color: #ffffff"><i class="fa fa-twitter"></i></a></span>
<span class="sr-whatsapp"><a rel="nofollow" href="https://api.whatsapp.com/send?text=Scientists+are+Teaching+Spinach+To+Send+Emails+and+Turning+Them+Into+Human+Hearts%20https://gadgets-africa.com/2021/02/21/spinach-sending-emails/" target="_blank" title="WhatsApp" style="color: #ffffff" data-mobile="whatsapp://send?text=Scientists+are+Teaching+Spinach+To+Send+Emails+and+Turning+Them+Into+Human+Hearts%20-%20https://gadgets-africa.com/2021/02/21/spinach-sending-emails/"><i class="fa fa-whatsapp"></i></a></span></div></div></div> </div>
<style type="text/css">
/*css for slider related post*/
svg {
display: block;
overflow: visible;
}
.slider-container {
position: relative;
height: 100%;
-webkit-user-select: none;
-moz-user-select: none;
-ms-user-select: none;
user-select: none;
cursor: all-scroll;
overflow: hidden;
margin-top:20px;
margin-bottom: 20px;
height:258px;
}
.slider-control {
z-index: 2;
position: absolute;
top: 0;
width: 12%;
height: 100%;
-webkit-transition: opacity 0.3s;
transition: opacity 0.3s;
opacity: 0;
}
.slider-control.inactive:hover { cursor: auto; }
.slider-control:not(.inactive):hover {
opacity: 1;
cursor: pointer;
}
.slider-control.left {
left: 0;
background: -webkit-linear-gradient(left, rgba(0, 0, 0, 0.18) 0%, rgba(0, 0, 0, 0) 100%);
background: linear-gradient(to right, rgba(0, 0, 0, 0.18) 0%, rgba(0, 0, 0, 0) 100%);
}
.slider-control.right {
right: 0;
background: -webkit-linear-gradient(left, rgba(0, 0, 0, 0) 0%, rgba(0, 0, 0, 0.18) 100%);
background: linear-gradient(to right, rgba(0, 0, 0, 0) 0%, rgba(0, 0, 0, 0.18) 100%);
}
.slider {
z-index: 1;
position: relative;
height: 100%;
}
.slider.animating {
-webkit-transition: -webkit-transform 0.5s;
transition: transform 0.5s;
}
.slider.animating .slide__bg {
-webkit-transition: -webkit-transform 0.5s;
transition: transform 0.5s;
}
.slide {
position: absolute;
top: 0;
width: 100%;
height: 100%;
overflow: hidden;
}
.slide.active .slide__overlay,
.slide.active .slide__text {
opacity: 1;
-webkit-transform: translateX(0);
-ms-transform: translateX(0);
transform: translateX(0);
}
.slide__bg {
width: 100%;
background-size: cover;
height: 250px;
position: absolute;
top: 0;
left: -50%;
height: 100%;
max-height:200px;
}
.slide:nth-child(1) { left: 0; }
.slide:nth-child(1) .slide__bg {
left: 0;
}
/*.slide .slide__text { background-color: #f1f1f1; max-width: 270px;}*/
.slide:nth-child(2) { left: 100%; }
.slide:nth-child(2) .slide__bg {
left: -50%;
}
.slide:nth-child(3) { left: 200%; }
.slide:nth-child(3) .slide__bg {
left: -100%;
}
.slide:nth-child(4) { left: 300%; }
.slide:nth-child(4) .slide__bg {
left: -150%;
}
.slide__content {
position: absolute;
top: 0;
left: 0;
width: 100%;
height: 100%;
}
.slide__text {
position: absolute;
width: 25%;
bottom: 15%;
left: 12%;
color: #fff;
-webkit-transition: -webkit-transform 0.5s 0.8s, opacity 0.5s 0.8s;
transition: transform 0.5s 0.8s, opacity 0.5s 0.8s;
-webkit-transform: translateY(-50%);
-ms-transform: translateY(-50%);
transform: translateY(-50%);
opacity: 0;
}
.slide__text .arrow{
position: absolute;
bottom: 3px;
right: 28px;
}
.slide__text .arrow i{
font-size: 20px;
color: #1fafc1;
font-weight: 900;
}
.slider-pagi {
position: absolute;
z-index: 3;
left: 10%;
bottom: 90px;
font-size: 0;
list-style-type: none;
width: 80%;
padding: 0;
right: 10%;
}
.slider-pagi__elem {
position: relative;
display: inline-block;
vertical-align: top;
width: 21.2%;
height: 3px;
margin: 0 0.3rem;
cursor: pointer;
background: #fff;
}
.slider-pagi__elem.active{
background: #1fafc1;
}
.top-arti {
color: #0D192D;
margin: 22px 18px;
text-transform: uppercase;
font-size: 12px;
font-weight: 400;
}
.top-arti span.top-text{
padding: 6px;
background-color: #FFFFFF;
}
.top-arti span.count{
background: #000;
color: #fff;
padding: 6px;
}
.slidehed.block-heading__title{
margin-top: 15px;
}
.mnmd-block.post--single{
margin-bottom: 0px!important;
}
@media (max-width: 991px) {
.slide__text {
left: 20px;
bottom: 18px;
width: 100%;
height: auto;
-webkit-transform: translateY(50%);
-ms-transform: translateY(50%);
transform: translateY(50%);
-webkit-transition: -webkit-transform 0.5s 0.5s, opacity 0.5s 0.5s;
transition: transform 0.5s 0.5s, opacity 0.5s 0.5s;
}
}
@media (max-width: 991px) {
.slide__text-heading {
transition: 0.3s;
color: #4c4e4d;
font-size: 15px;
line-height: 18px;
font-weight: 500;
margin-bottom: 0;
padding: 8px;
text-align: left;
border-left: 7px solid #1fafc1;
max-width: 260px;
background-color: #f1f1f1;
}
}
/*ends here */
</style>
<div class="des-dfpad">

<footer class="single-footer entry-footer">
<div class="entry-info">
<div class="row row--space-between grid-gutter-10">
<div class="entry-categories col-sm-6">
<ul>
<li class="entry-categories__icon"><i class="mdicon mdicon-folder"></i><span class="sr-only">Posted in</span></li>
<li><a class="cat-8 entry-cat cat-theme" href="https://gadgets-africa.com/category/more/editorial/">Editorial</a></li>
</ul>
</div>
<div class="entry-tags col-sm-6">
<ul>
<li class="entry-tags__icon"><i class="mdicon mdicon-local_offer"></i><span class="sr-only">Tagged with</span></li>
<li><a class="post-tag" rel="tag" href="https://gadgets-africa.com/tag/emails/">emails</a></li><li><a class="post-tag" rel="tag" href="https://gadgets-africa.com/tag/spinach/">Spinach</a></li>
</ul>
</div>
</div>
</div>
<div class="entry-interaction entry-interaction--horizontal">
<div class="entry-interaction__left">
<div class="post-sharing post-sharing--simple">
<ul>
</ul>
</div>
</div>
<div class="entry-interaction__right">
<a href="#comments" class="comments-count entry-action-btn" data-toggle="tooltip" data-placement="top" title="0 Comments"><i class="mdicon mdicon-chat_bubble"></i><span>0</span></a> </div>
</div>
</footer>
<div class="my-4 side-video">
<h4 class="mt-4">Swvl- Breaking The Matatu Mould, Surviving 2020 and New Carpool Service</h4>
<iframe id="ytplayer" src="https://www.youtube.com/embed/fslbQFtFMnQ?rel=0&autoplay=0&mute=1&showinfo=0&controls=1&loop=1&enablejsapi=1&modestbranding=1" frameborder="0"></iframe>
<style type="text/css">

        iframe{

            width: 100%;

            min-height: 350px;

        }

       @media screen and (max-width: 600px) {

        iframe{

            min-height: 200px!important;

        }

       }

    </style>
</div>
<script src="https://code.jquery.com/jquery-3.2.1.slim.min.js" integrity="sha384-KJ3o2DKtIkvYIK3UENzmM7KCkRr/rE9/Qpg6aAZGJwFDMVNA/GpGFF93hXpG5KkN" crossorigin="anonymous"></script>
<script>
$(document).ready(function() {
var $slider = $(".slider"),
$slideBGs = $(".slide__bg"),
diff = 0,
curSlide = 0,
numOfSlides = $(".slide").length-1,
animating = false,
animTime = 500,
autoSlideTimeout,
autoSlideDelay = 6000,
$pagination = $(".slider-pagi");
function createBullets() {
for (var i = 0; i < numOfSlides+1; i++) {
  var $li = $("<li class='slider-pagi__elem'></li>");
  $li.addClass("slider-pagi__elem-"+i).data("page", i);
  if (!i) $li.addClass("active");
  $pagination.append($li);
}
};
createBullets();
function manageControls() {
$(".slider-control").removeClass("inactive");
if (!curSlide) $(".slider-control.left").addClass("inactive");
if (curSlide === numOfSlides) $(".slider-control.right").addClass("inactive");
};
function autoSlide() {
autoSlideTimeout = setTimeout(function() {
curSlide++;
if (curSlide > numOfSlides) curSlide = 0;
changeSlides();
}, autoSlideDelay);
};
autoSlide();
function changeSlides(instant) {
if (!instant) {
animating = true;
manageControls();
$slider.addClass("animating");
$slider.css("top");
$(".slide").removeClass("active");
$(".slide-"+curSlide).addClass("active");
setTimeout(function() {
$slider.removeClass("animating");
animating = false;
}, animTime);
}
window.clearTimeout(autoSlideTimeout);
$(".slider-pagi__elem").removeClass("active");
$(".slider-pagi__elem-"+curSlide).addClass("active");
$slider.css("transform", "translate3d("+ -curSlide*100 +"%,0,0)");
$slideBGs.css("transform", "translate3d("+ curSlide*50 +"%,0,0)");
diff = 0;
autoSlide();
}
function navigateLeft() {
if (animating) return;
if (curSlide > 0) curSlide--;
changeSlides();
}
function navigateRight() {
if (animating) return;
if (curSlide < numOfSlides) curSlide++;
changeSlides();
}
$(document).on("mousedown touchstart", ".slider", function(e) {
if (animating) return;
window.clearTimeout(autoSlideTimeout);
var startX = e.pageX || e.originalEvent.touches[0].pageX,
winW = $(window).width();
diff = 0;
$(document).on("mousemove touchmove", function(e) {
var x = e.pageX || e.originalEvent.touches[0].pageX;
diff = (startX - x) / winW * 70;
if ((!curSlide && diff < 0) || (curSlide === numOfSlides && diff > 0)) diff /= 2;
$slider.css("transform", "translate3d("+ (-curSlide*100 - diff) +"%,0,0)");
$slideBGs.css("transform", "translate3d("+ (curSlide*50 + diff/2) +"%,0,0)");
});
});
$(document).on("mouseup touchend", function(e) {
$(document).off("mousemove touchmove");
if (animating) return;
if (!diff) {
changeSlides(true);
return;
}
if (diff > -8 && diff < 8) {
changeSlides();
return;
}
if (diff <= -8) {
navigateLeft();
}
if (diff >= 8) {
navigateRight();
}
});
$(document).on("click", ".slider-control", function() {
if ($(this).hasClass("left")) {
navigateLeft();
} else {
navigateRight();
}
});
$(document).on("click", ".slider-pagi__elem", function() {
curSlide = $(this).data("page");
changeSlides();
});
});
</script> </div>
</div>
</article>
<div class="mnmd-block mnmd-block--fullwidth related-posts has-background lightgray-bg"><div class="container"><div class="block-heading "><h4 class="block-heading__title">More in <a href="https://gadgets-africa.com/category/more/editorial/" class="cat-8 cat-theme">Editorial</a></h4></div><div class="row row--space-between"><div class="col-xs-12 col-sm-6 col-md-3"> <article class="post post--card post--card-sm text-center post--vertical-cat-overlap">
<div class="post__thumb">
<a href="https://gadgets-africa.com/2021/02/02/silhouette-challenge/">
<div class="background-img" style="background-image: url('https://i1.wp.com/gadgets-africa.com/wp-content/uploads/2021/02/Untitled-design-18.jpg?resize=400%2C225&#038;ssl=1');"></div>
</a>
<a class="cat-8 post__cat post__cat--bg post__cat--overlap cat-theme-bg" href="https://gadgets-africa.com/category/more/editorial/">Editorial</a> </div>
<div class="post__text ">
<h3 class="post__title typescale-1"><a href="https://gadgets-africa.com/2021/02/02/silhouette-challenge/">One Group Creates the Silhouette Challenge Videos, The Other Wants To See Through Them</a></h3>
</div>
<div class="post__footer text-center">
<div class="post__meta">
<time class="time published" datetime="2021-02-02T09:00:19+00:00" title="February 2, 2021 at 9:00 am"><i class="mdicon mdicon-schedule"></i>February 2, 2021</time><span><a title="0 Comments" href="https://gadgets-africa.com/2021/02/02/silhouette-challenge/"><i class="mdicon mdicon-chat_bubble_outline"></i>0</a></span> </div>
</div>
</article>
</div><div class="col-xs-12 col-sm-6 col-md-3"> <article class="post post--card post--card-sm text-center post--vertical-cat-overlap">
<div class="post__thumb">
<a href="https://gadgets-africa.com/2021/01/11/parler-the-end-of-free-speech/">
<div class="background-img" style="background-image: url('https://i1.wp.com/gadgets-africa.com/wp-content/uploads/2021/01/parler-2-gty-er-201116_1605563678234_hpEmbed_23x15_992.jpg?resize=400%2C225&#038;ssl=1');"></div>
</a>
<a class="cat-7 post__cat post__cat--bg post__cat--overlap cat-theme-bg" href="https://gadgets-africa.com/category/software/apps/">Apps</a> </div>
<div class="post__text ">
<h3 class="post__title typescale-1"><a href="https://gadgets-africa.com/2021/01/11/parler-the-end-of-free-speech/">What Exactly is Parler and Why is Everyone Banning It?</a></h3>
</div>
<div class="post__footer text-center">
<div class="post__meta">
<time class="time published" datetime="2021-01-11T12:35:13+00:00" title="January 11, 2021 at 12:35 pm"><i class="mdicon mdicon-schedule"></i>January 11, 2021</time><span><a title="0 Comments" href="https://gadgets-africa.com/2021/01/11/parler-the-end-of-free-speech/"><i class="mdicon mdicon-chat_bubble_outline"></i>0</a></span> </div>
</div>
</article>
</div><div class="clearfix visible-sm"></div><div class="col-xs-12 col-sm-6 col-md-3"> <article class="post post--card post--card-sm text-center post--vertical-cat-overlap">
<div class="post__thumb">
<a href="https://gadgets-africa.com/2020/12/31/our-biggest-stories-from-the-longest-and-shortest-year-2020/">
<div class="background-img" style="background-image: url('https://i0.wp.com/gadgets-africa.com/wp-content/uploads/2020/12/top-stories-2020.jpg?resize=400%2C225&#038;ssl=1');"></div>
</a>
<a class="cat-8 post__cat post__cat--bg post__cat--overlap cat-theme-bg" href="https://gadgets-africa.com/category/more/editorial/">Editorial</a> </div>
<div class="post__text ">
<h3 class="post__title typescale-1"><a href="https://gadgets-africa.com/2020/12/31/our-biggest-stories-from-the-longest-and-shortest-year-2020/">Our Biggest Stories From The Longest and Shortest Year, 2020!</a></h3>
</div>
<div class="post__footer text-center">
<div class="post__meta">
<time class="time published" datetime="2020-12-31T12:12:12+00:00" title="December 31, 2020 at 12:12 pm"><i class="mdicon mdicon-schedule"></i>December 31, 2020</time><span><a title="0 Comments" href="https://gadgets-africa.com/2020/12/31/our-biggest-stories-from-the-longest-and-shortest-year-2020/"><i class="mdicon mdicon-chat_bubble_outline"></i>0</a></span> </div>
</div>
</article>
</div><div class="col-xs-12 col-sm-6 col-md-3"> <article class="post post--card post--card-sm text-center post--vertical-cat-overlap">
<div class="post__thumb">
<a href="https://gadgets-africa.com/2020/11/26/is-twitter-toxic-uhuru-reveals/">
<div class="background-img" style="background-image: url('https://i2.wp.com/gadgets-africa.com/wp-content/uploads/2020/11/images-10.jpeg?resize=400%2C225&#038;ssl=1');"></div>
</a>
<a class="cat-8 post__cat post__cat--bg post__cat--overlap cat-theme-bg" href="https://gadgets-africa.com/category/more/editorial/">Editorial</a> </div>
<div class="post__text ">
<h3 class="post__title typescale-1"><a href="https://gadgets-africa.com/2020/11/26/is-twitter-toxic-uhuru-reveals/">Is Twitter Really That Toxic? President Uhuru Reveals Why He Deleted his Twitter Account</a></h3>
</div>
<div class="post__footer text-center">
<div class="post__meta">
<time class="time published" datetime="2020-11-26T09:23:10+00:00" title="November 26, 2020 at 9:23 am"><i class="mdicon mdicon-schedule"></i>November 26, 2020</time><span><a title="0 Comments" href="https://gadgets-africa.com/2020/11/26/is-twitter-toxic-uhuru-reveals/"><i class="mdicon mdicon-chat_bubble_outline"></i>0</a></span> </div>
</div>
</article>
</div></div><nav class="mnmd-pagination text-center"><a href="https://gadgets-africa.com/category/more/editorial/" class="btn btn-default">View all Editorial<i class="mdicon mdicon-arrow_forward mdicon--last"></i></a></nav></div></div> 
<div class="mnmd-block mnmd-block--fullwidth comments-section">
<div class="container container--narrow">
<div id="comments" class="comments-area">
<h2 class="comments-title">
Comments </h2>
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Share Your Opinion <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2021/02/21/spinach-sending-emails/#respond" style="display:none;">Cancel reply</a></small>
</h3>
<form id="commentform" class="comment-form">
<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=156559661&#038;postid=21627&#038;comment_registration=0&#038;require_name_email=0&#038;stc_enabled=0&#038;stb_enabled=0&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Share+Your+Opinion&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_GB&#038;jetpack_version=8.7.1&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=d5c9a86f64cc42d5fc859fac4a2e80af6eca95b0#parent=https%3A%2F%2Fgadgets-africa.com%2F2021%2F02%2F21%2Fspinach-sending-emails%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"></iframe>
<!--[if !IE]><!-->
<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
<!--<![endif]-->
</form>
</div>
<input type="hidden" name="comment_parent" id="comment_parent" value="" />
</div>
</div>
</div>
</div>
</div>

<footer class="site-footer footer-2  has-bg-pattern  site-footer--inverse inverse-text">
<div class="site-footer__section">
<div class="container">
<div class="row">
<div class="col-md-3 text-left">
<div class="site-footer__section-inner">
<div class="site-logo">
<img src="https://gadgets-africa.com/wp-content/themes/the-next-mag/img/gadget-africa-logo.png">
</div>
</div>
</div>
<div class="col-md-6">
<nav class="footer-menu text-center">
<div class="menu-footer-container"><ul id="menu-footer" class="navigation navigation--footer navigation--inline"><li id="menu-item-6254" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6254"><a href="https://gadgets-africa.com/about-gadgets-africa/">About Us</a></li>
<li id="menu-item-6974" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6974"><a href="https://gadgets-africa.com/advertise/">Advertise With Us</a></li>
<li id="menu-item-2681" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2681"><a href="https://gadgets-africa.com/disclaimer/">Disclaimer</a></li>
<li id="menu-item-2683" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2683"><a href="https://gadgets-africa.com/editorial-policy/">Editorial Policy</a></li>
<li id="menu-item-2682" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-2682"><a href="https://gadgets-africa.com/privacy-policy/">Privacy Policy</a></li>
</ul></div> </nav>
<div class="site-footer__section">
<ul class="social-list social-list--lg list-center">
<li><a href="https://www.facebook.com/gadgetsafrica/" target="_blank"><i class="mdicon mdicon-facebook"></i></a></li><li><a href="https://twitter.com/gadgetsafrica" target="_blank"><i class="mdicon mdicon-twitter"></i></a></li><li><a href="https://www.instagram.com/gadgetsafrica/" target="_blank"><i class="mdicon mdicon-instagram"></i></a></li><li><a href="https://www.youtube.com/gadgetsafrica" target="_blank"><i class="mdicon mdicon-youtube"></i></a></li> </ul>
</div>
</div>
<div class="col-md-3 text-right">

<a href="http://weemedia.africa" target="_blank">

<img src="https://gadgets-africa.com/wp-content/uploads/2019/01/weemedIa.png" alt="logo" width="100" />

</a>
</div>
</div>
</div>
</div>
</footer>

<div id="mnmd-offcanvas-mobile" class="mnmd-offcanvas js-mnmd-offcanvas js-perfect-scrollbar">
<div class="mnmd-offcanvas__title">
<h2 class="site-logo">
<a href="https://gadgets-africa.com">

<img src="https://gadgets-africa.com/wp-content/uploads/2020/02/canvaslogo.jpg" alt="logo" />

</a>
</h2>
<ul class="social-list list-horizontal">
<li><a href="https://www.facebook.com/gadgetsafrica/" target="_blank"><i class="mdicon mdicon-facebook"></i></a></li><li><a href="https://twitter.com/gadgetsafrica" target="_blank"><i class="mdicon mdicon-twitter"></i></a></li><li><a href="https://www.instagram.com/gadgetsafrica/" target="_blank"><i class="mdicon mdicon-instagram"></i></a></li><li><a href="https://www.youtube.com/gadgetsafrica" target="_blank"><i class="mdicon mdicon-youtube"></i></a></li>
</ul>
<a href="#mnmd-offcanvas-mobile" class="mnmd-offcanvas-close js-mnmd-offcanvas-close" aria-label="Close"><span aria-hidden="true">&#10005;</span></a>
</div>
<div class="mnmd-offcanvas__section mnmd-offcanvas__section-navigation">
<div id="offcanvas-menu-mobile" class="menu-newmain_menu-container"><ul id="menu-newmain_menu-1" class="navigation navigation--offcanvas"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10340 menu-item-cat-7"><a href="https://gadgets-africa.com/category/software/apps/">Apps</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21344 menu-item-cat-212"><a href="https://gadgets-africa.com/category/more/cars/">Automobiles</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10314 menu-item-cat-587"><a href="https://gadgets-africa.com/category/gaming/">Gaming</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10318 menu-item-cat-209"><a href="https://gadgets-africa.com/category/home-tech/">Home Electronics</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18381 menu-item-cat-207"><a href="https://gadgets-africa.com/category/mobile/laptops/">Laptops</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21345 menu-item-cat-13"><a href="https://gadgets-africa.com/category/more/lists/">Lists</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18382 menu-item-cat-206"><a href="https://gadgets-africa.com/category/mobile/smartphones/">Smartphones</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21346 menu-item-cat-1275"><a href="https://gadgets-africa.com/category/more/governance/">Tech &#038; Governance</a></li>
</ul></div>
</div>
</div>
<a href="#" class="mnmd-go-top btn btn-default hidden-xs js-go-top-el"><i class="mdicon mdicon-arrow_upward"></i></a>
</div>
<script src="https://kit.fontawesome.com/685b6f4a9a.js"></script>
<script src="https://emailoctopus.com/bundles/emailoctopuslist/js/1.4/formEmbed.js"></script>
<script src="https://ajax.googleapis.com/ajax/libs/jquery/3.4.1/jquery.min.js"></script>
<script src="https://maxcdn.bootstrapcdn.com/bootstrap/4.0.0/js/bootstrap.min.js"></script>

<script>var wpsr_ajax_url = "https://gadgets-africa.com/wp-admin/admin-ajax.php";</script>

<ul class="wpsr-text-sb wpsr-tsb-32px wpsr-clearfix" data-content=".entry-content" data-tcount="20" style="background-color: #ffffff" data-url="https://gadgets-africa.com/2021/02/21/spinach-sending-emails/" data-title="Scientists are Teaching Spinach To Send Emails and Turning Them Into Human Hearts" data-surl="https://wp.me/paAUjP-5CP" data-tuname="@gadgetsafrica"><li><a href="#" title="Share this on Facebook" data-link="https://www.facebook.com/share.php?u={url}&amp;quote={excerpt}" style="color: #1e73be"><i class="fa fa-facebook-f"></i></a></li><li><a href="#" title="Tweet this !" data-link="https://twitter.com/intent/tweet?text={excerpt}%20-%20{url}%20{twitter-username}" style="color: #1e73be"><i class="fa fa-twitter"></i></a></li></ul><script type="text/javascript" src="https://a.omappapi.com/app/js/api.min.js" data-campaign="duztqpld90o3oyrfn9vq" data-user="51542"></script><script type="text/javascript" src="https://a.omappapi.com/app/js/api.min.js" data-campaign="dhdcg6bbt9ej7yomap35" data-user="51542"></script><script type="text/javascript" src="https://a.omappapi.com/app/js/api.min.js" data-campaign="yyv4xxqaisgcu5xzvrjh" data-user="51542"></script><script type="text/javascript" src="https://a.omappapi.com/app/js/api.min.js" data-campaign="bhd5dmpwvxxbajopqgft" data-user="51542"></script> <script type="text/javascript">
		var duztqpld90o3oyrfn9vq_shortcode = true;var dhdcg6bbt9ej7yomap35_shortcode = true;var yyv4xxqaisgcu5xzvrjh_shortcode = true;var bhd5dmpwvxxbajopqgft_shortcode = true;		</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.7.1/_inc/build/photon/photon.min.js' defer='defer'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/gadgets-africa.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://gadgets-africa.com/wp-content/plugins/contact-form-7/includes/js/scripts.js' defer='defer'></script>
<script type='text/javascript' src='https://gadgets-africa.com/wp-content/plugins/tnm-shortcode/js/shortcode.js' defer='defer'></script>
<script type='text/javascript' src='https://gadgets-africa.com/wp-content/plugins/twenty20/assets/js/jquery.twenty20.js' defer='defer'></script>
<script type='text/javascript' src='https://gadgets-africa.com/wp-content/plugins/twenty20/assets/js/jquery.event.move.js' defer='defer'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.6/wp-includes/js/jquery/ui/widget.min.js' defer='defer'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.6/wp-includes/js/jquery/ui/core.min.js' defer='defer'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.6/wp-includes/js/jquery/ui/tabs.min.js' defer='defer'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.6/wp-includes/js/jquery/ui/accordion.min.js' defer='defer'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.6/wp-includes/js/imagesloaded.min.js' defer='defer'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.6/wp-includes/js/masonry.min.js' defer='defer'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.6/wp-includes/js/jquery/jquery.masonry.min.js' defer='defer'></script>
<script type='text/javascript' src='https://gadgets-africa.com/wp-content/themes/the-next-mag/js/vendors/throttle-debounce.min.js' defer='defer'></script>
<script type='text/javascript' src='https://gadgets-africa.com/wp-content/themes/the-next-mag/js/vendors/bootstrap.min.js' defer='defer'></script>
<script type='text/javascript' src='https://gadgets-africa.com/wp-content/themes/the-next-mag/js/vendors/countdown.min.js' defer='defer'></script>
<script type='text/javascript' src='https://gadgets-africa.com/wp-content/themes/the-next-mag/js/vendors/flickity.min.js' defer='defer'></script>
<script type='text/javascript' src='https://gadgets-africa.com/wp-content/themes/the-next-mag/js/vendors/fotorama.min.js' defer='defer'></script>
<script type='text/javascript' src='https://gadgets-africa.com/wp-content/themes/the-next-mag/js/vendors/magnific-popup.min.js' defer='defer'></script>
<script type='text/javascript' src='https://gadgets-africa.com/wp-content/themes/the-next-mag/js/vendors/owl-carousel.min.js' defer='defer'></script>
<script type='text/javascript' src='https://gadgets-africa.com/wp-content/themes/the-next-mag/js/vendors/perfect-scrollbar.min.js' defer='defer'></script>
<script type='text/javascript' src='https://gadgets-africa.com/wp-content/themes/the-next-mag/js/vendors/theiaStickySidebar.min.js' defer='defer'></script>
<script type='text/javascript' src='https://gadgets-africa.com/wp-content/themes/the-next-mag/js/vendors/vticker.min.js' defer='defer'></script>
<script type='text/javascript' src='https://gadgets-africa.com/wp-content/themes/the-next-mag/js/vendors/fitvids.js' defer='defer'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_buff = {"tnm_security":{"tnm_security_code":{"content":"e22cfa4f5a"}}};
/* ]]> */
</script>
<script type='text/javascript' src='https://gadgets-africa.com/wp-content/themes/the-next-mag/js/scripts.js' defer='defer'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.6/wp-includes/js/comment-reply.min.js' defer='defer'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var emailoctopus = {"ajaxurl":"https:\/\/gadgets-africa.com\/wp-admin\/admin-ajax.php","sending":"Sending"};
/* ]]> */
</script>
<script type='text/javascript' src='https://gadgets-africa.com/wp-content/plugins/emailoctopus/js/frontend.min.js' defer='defer'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.7.1/_inc/build/widgets/eu-cookie-law/eu-cookie-law.min.js' defer='defer'></script>
<script type='text/javascript'>
function heateorSssLoadEvent(e) {var t=window.onload;if (typeof window.onload!="function") {window.onload=e}else{window.onload=function() {t();e()}}};	var heateorSssSharingAjaxUrl = 'https://gadgets-africa.com/wp-admin/admin-ajax.php', heateorSssCloseIconPath = 'https://gadgets-africa.com/wp-content/plugins/sassy-social-share/public/../images/close.png', heateorSssPluginIconPath = 'https://gadgets-africa.com/wp-content/plugins/sassy-social-share/public/../images/logo.png', heateorSssHorizontalSharingCountEnable = 0, heateorSssVerticalSharingCountEnable = 0, heateorSssSharingOffset = -10; var heateorSssMobileStickySharingEnabled = 0;var heateorSssCopyLinkMessage = "Link copied.";var heateorSssUrlCountFetched = [], heateorSssSharesText = 'Shares', heateorSssShareText = 'Share';function heateorSssPopup(e) {window.open(e,"popUpWindow","height=400,width=600,left=400,top=100,resizable,scrollbars,toolbar=0,personalbar=0,menubar=no,location=no,directories=no,status")};var heateorSssWhatsappShareAPI = "web";
</script>
<script type='text/javascript' src='https://gadgets-africa.com/wp-content/plugins/sassy-social-share/public/js/sassy-social-share-public.js' defer='defer'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.7.1/_inc/build/lazy-images/js/lazy-images.min.js' defer='defer'></script>
<script>(function(d){var s=d.createElement("script");s.type="text/javascript";s.src="https://a.omappapi.com/app/js/api.min.js' defer='defer";s.async=true;s.id="omapi-script";d.getElementsByTagName("head")[0].appendChild(s);})(document);</script><script type='text/javascript' src='https://c0.wp.com/c/5.3.6/wp-includes/js/wp-embed.min.js' defer='defer'></script>
<script async="async" type='text/javascript' src='https://gadgets-africa.com/wp-content/plugins/akismet/_inc/form.js' defer='defer'></script>
<script type='text/javascript' src='https://gadgets-africa.com/wp-content/plugins/wp-socializer/public/js/wp-socializer.min.js' defer='defer'></script>
<script type='text/javascript' src='https://gadgets-africa.com/wp-content/plugins/optinmonster/assets/js/helper.js' defer='defer'></script>
<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=156559661&postid=21627&comment_registration=0&require_name_email=0&stc_enabled=0&stb_enabled=0&show_avatars=1&avatar_default=mystery&greeting=Share+Your+Opinion&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_GB&jetpack_version=8.7.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=d5c9a86f64cc42d5fc859fac4a2e80af6eca95b0#parent=https%3A%2F%2Fgadgets-africa.com%2F2021%2F02%2F21%2Fspinach-sending-emails%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=156559661&postid=21627&comment_registration=0&require_name_email=0&stc_enabled=0&stb_enabled=0&show_avatars=1&avatar_default=mystery&greeting=Share+Your+Opinion&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_GB&jetpack_version=8.7.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=d5c9a86f64cc42d5fc859fac4a2e80af6eca95b0#parent=https%3A%2F%2Fgadgets-africa.com%2F2021%2F02%2F21%2Fspinach-sending-emails%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>
<script type='text/javascript' src='https://stats.wp.com/e-202107.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.7.1',blog:'156559661',post:'21627',tz:'3',srv:'gadgets-africa.com'} ]);
	_stq.push([ 'clickTrackerInit', '156559661', '21627' ]);
</script>
<script type="text/javascript">var omapi_localized = { ajax: 'https://gadgets-africa.com/wp-admin/admin-ajax.php?optin-monster-ajax-route=1', nonce: 'a8b1aa4926', slugs: {"duztqpld90o3oyrfn9vq":{"slug":"duztqpld90o3oyrfn9vq","mailpoet":false},"dhdcg6bbt9ej7yomap35":{"slug":"dhdcg6bbt9ej7yomap35","mailpoet":false},"yyv4xxqaisgcu5xzvrjh":{"slug":"yyv4xxqaisgcu5xzvrjh","mailpoet":false},"bhd5dmpwvxxbajopqgft":{"slug":"bhd5dmpwvxxbajopqgft","mailpoet":false}} };</script>
<script type="text/javascript">var omapi_data = {"wc_cart":[],"object_id":21627,"object_key":"post","object_type":"post","term_ids":[8,2468,2579]};</script>
<script type="application/javascript">

var truepushSDK = document.createElement('script');

truepushSDK.setAttribute('src','https://app.truepush.com/sdk/app.js?key=5c76ad8479cb29161ebc8db6&reload='+new Date().getTime());

document.head.appendChild(truepushSDK);

</script>
<script>
function init() {
  var imgDefer = document.getElementsByTagName('img');
  for (var i = 0; i < imgDefer.length; i++) {
    if (imgDefer[i].getAttribute('data-src')) {
      imgDefer[i].setAttribute('src',imgDefer[i].getAttribute('data-src'));
    }
  }
}

window.onload = init;
</script>

<script type="text/javascript" src="https://a.opmnstr.com/app/js/api.min.js" data-account="58001" data-user="51542" async></script>


<script type="text/javascript" src="https://a.omappapi.com/app/js/api.min.js" data-account="58001" data-user="51542" async></script>

</body>
</html>
<div class="mobile-sticky-share sticky-share text-center" id="sticky-share">
<div class="container">
<div class="row">
<div class="col-md-12 text-center">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:320px;height:50px" data-ad-client="ca-pub-3549148798608953" data-ad-slot="1186489088"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
</div>
</div>
</div>
</div>
